Post by robatmid » Thu Jul 05, 2018 11:59 pm

I'm upgrading to OC 2.3.0.2, and see system requirements for PHP are 5.4+... is it safe to use PHP 7.2? Can anyone confirm its working well?

Newbie

Posts

Joined
Tue Aug 13, 2013 9:42 pm

Post by straightlight » Fri Jul 06, 2018 12:11 am

Better to use OC v3.x releases for the most recent OC versions. However, using v2.3.0.2 on a test environment before launching it live with PHP v7.2 would also be ideal.

The most generated errors being found on Opencart forum originates from contributed programming. The increased counters are caused by posted redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by thekrotek » Fri Jul 06, 2018 12:38 am

Plea
straightlight wrote:
Fri Jul 06, 2018 12:11 am
Better to use OC v3.x releases for the most recent OC versions.
It's far from better, it's worse. OC 2.3 is much more stable and highly recommended to use instead of any OC 3 version, which is actually OC 2.4.

Professional OpenCart extensions, support and custom work.
Contact me via email or Skype by support@thekrotek.com


User avatar
Active Member

Posts

Joined
Sun Jul 03, 2016 12:24 am


Post by straightlight » Fri Jul 06, 2018 1:08 am

Didn't encountered any issues with it after fixing most of the posted bugs. The rest goes behind the desk.

The most generated errors being found on Opencart forum originates from contributed programming. The increased counters are caused by posted redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by robatmid » Fri Jul 06, 2018 2:17 am

Based on the poor End-User and Professional reviews of OC version 3...., I'll stay away until a stable/favorable version is released.
Regarding original PHP version question. Is safe or smart to go to 7.2 running OC 2.3.0.2?

Newbie

Posts

Joined
Tue Aug 13, 2013 9:42 pm

Post by agatha65 » Fri Jul 06, 2018 3:25 am

+1 for 2.3.0.2
There was something that is not working with php 7.2 I remember there was a discussion here on forum and I think the fix was published. Just try and if something is not working downgrade to 7.1.
I can confirm that php7.1 is OK.

Print Version for Product Page and Product Compare Page | Rich Snippets | Facebook Open Graph Meta Tags | Information pages in top menu | Multi-Language Banners, Sliders and Carousels
Image


User avatar
Active Member

Posts

Joined
Fri Mar 16, 2012 10:18 am
Location - Canada, QC

Post by straightlight » Fri Jul 06, 2018 4:30 am

Just try and if something is not working downgrade to 7.1.
I can confirm that php7.1 is OK.
So rather than providing the topic where the patch has been posted on the forum, users are instead encouraged to downgrade their PHP versions rather than solving the actual issue with PHP v7.2 by posting what one-to-many people can encounter to rectify the issue in the future? WTG!

The most generated errors being found on Opencart forum originates from contributed programming. The increased counters are caused by posted redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by Elevate » Sat Jul 07, 2018 4:05 am

straightlight wrote:
Fri Jul 06, 2018 4:30 am
Just try and if something is not working downgrade to 7.1.
I can confirm that php7.1 is OK.
So rather than providing the topic where the patch has been posted on the forum, users are instead encouraged to downgrade their PHP versions rather than solving the actual issue with PHP v7.2 by posting what one-to-many people can encounter to rectify the issue in the future? WTG!
OC 2.3.0.2 was released Aug 1, 2016 and php 7.2 was released Nov 30 2017

php 7.0.9 was released Jul 21, 2016 so I think I'd be very cautious trying to use php 7.1 or 7.2 with OC 2.3.0.2

Elevate
Custom Website Developers
https://www.elev8your.com


Newbie

Posts

Joined
Fri Jul 06, 2018 12:40 am
Location - Denver, Colorado, USA

Post by straightlight » Sat Jul 07, 2018 6:19 am

Elevate wrote:
Sat Jul 07, 2018 4:05 am
straightlight wrote:
Fri Jul 06, 2018 4:30 am
Just try and if something is not working downgrade to 7.1.
I can confirm that php7.1 is OK.
So rather than providing the topic where the patch has been posted on the forum, users are instead encouraged to downgrade their PHP versions rather than solving the actual issue with PHP v7.2 by posting what one-to-many people can encounter to rectify the issue in the future? WTG!
OC 2.3.0.2 was released Aug 1, 2016 and php 7.2 was released Nov 30 2017

php 7.0.9 was released Jul 21, 2016 so I think I'd be very cautious trying to use php 7.1 or 7.2 with OC 2.3.0.2
OC v2.3.0.2 has been released on August 2016 and OC v3.0.2.0 has been released on July 18 2017.

The most generated errors being found on Opencart forum originates from contributed programming. The increased counters are caused by posted redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by Elevate » Sun Jul 08, 2018 2:58 am

straightlight wrote:
Sat Jul 07, 2018 6:19 am
Elevate wrote:
Sat Jul 07, 2018 4:05 am
straightlight wrote:
Fri Jul 06, 2018 4:30 am


So rather than providing the topic where the patch has been posted on the forum, users are instead encouraged to downgrade their PHP versions rather than solving the actual issue with PHP v7.2 by posting what one-to-many people can encounter to rectify the issue in the future? WTG!
OC 2.3.0.2 was released Aug 1, 2016 and php 7.2 was released Nov 30 2017

php 7.0.9 was released Jul 21, 2016 so I think I'd be very cautious trying to use php 7.1 or 7.2 with OC 2.3.0.2
OC v2.3.0.2 has been released on August 2016 and OC v3.0.2.0 has been released on July 18 2017.
Correct. The original question was about using 2.3.0.2 with php7.2 and I think anyone needs to be very cautious doing this since 2.3.0.2 was released long before php 7.2.

Elevate
Custom Website Developers
https://www.elev8your.com


Newbie

Posts

Joined
Fri Jul 06, 2018 12:40 am
Location - Denver, Colorado, USA

Post by affect » Tue Jul 10, 2018 4:33 pm

We've been using 2.3.0.2 + PHP 7.2 as our default development environment here at MultiMerch with no issues so far.

Good to see OC 3.1 ditch 5.4, too – no reason to support a version that ancient.

MultiMerch Marketplace for OpenCart

Image


User avatar
Active Member

Posts

Joined
Sat Aug 13, 2011 5:04 pm


Post by Elevate » Wed Jul 11, 2018 4:03 am

affect wrote:
Tue Jul 10, 2018 4:33 pm
We've been using 2.3.0.2 + PHP 7.2 as our default development environment here at MultiMerch with no issues so far.

Good to see OC 3.1 ditch 5.4, too – no reason to support a version that ancient.
I personally think 3.1 and higher need to ditch all 5.x versions. EOL for 5.6 security support is the end of this year.
http://php.net/supported-versions.php

Elevate
Custom Website Developers
https://www.elev8your.com


Newbie

Posts

Joined
Fri Jul 06, 2018 12:40 am
Location - Denver, Colorado, USA

Post by affect » Wed Jul 11, 2018 4:20 am

Elevate wrote:
Wed Jul 11, 2018 4:03 am
affect wrote:
Tue Jul 10, 2018 4:33 pm
We've been using 2.3.0.2 + PHP 7.2 as our default development environment here at MultiMerch with no issues so far.

Good to see OC 3.1 ditch 5.4, too – no reason to support a version that ancient.
I personally think 3.1 and higher need to ditch all 5.x versions. EOL for 5.6 security support is the end of this year.
http://php.net/supported-versions.php
Yup, that's exactly what's going on: https://github.com/opencart/opencart/co ... a87bda2b39

Just about time.

MultiMerch Marketplace for OpenCart

Image


User avatar
Active Member

Posts

Joined
Sat Aug 13, 2011 5:04 pm


Post by AM786 » Fri Jul 13, 2018 4:47 am

I've seen discussions regarding mcrypt not working and even a solution.

I'm not too familiar with mcrypt. What features/extensions of a website would require one to use this solution? Or is the solution needed for every oc 2.3.0.2 on php 7.2 ?

New member

Posts

Joined
Sat Jul 07, 2018 3:49 am

Post by straightlight » Fri Jul 13, 2018 5:19 am

I'm not too familiar with mcrypt. What features/extensions of a website would require one to use this solution? Or is the solution needed for every oc 2.3.0.2 on php 7.2 ?
One way to find out is to test that solution. ;)

The most generated errors being found on Opencart forum originates from contributed programming. The increased counters are caused by posted redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON
Who is online

Users browsing this forum: DigitCart, FrogMan and 12 guests