Post by Gohloum » Thu Jul 05, 2018 11:54 pm

Hello,

I recently took over a running Opencart project that is currently 2.2.0.0. I come from a Ruby on Rails and mobile development background and PHP experience. Looking through the docs, I have a reasonable understanding of how the technology is setup in an MVC-L fashion. Nothing new here. The only thing I have not worked with is TWIG and Smarty (tpl).

The client will want me to develop a few custom extension for him. A few on the front end, but more for the back end for admin purposes and reports. Therefore, before I get my hands dirty, I am wondering if I should tackle upgrading to 3.x first or if 2.2.0.0 is stable and secure to keep online?

Poking around in the docs and Wiki, there seems to be more complete documentation on building extensions for the 2.x flavor. The wiki for 3.x is incomplete. Also I am aware that TWIG is deployed in 3.x where Smarty in 2.x. I'd rather not have to dive into 2 template languages, but I really don't know the pros and cons of each to the other.

Generally, with software, the newer versions address security risks that pop up over time. Are there any known risks or breaches in 2.2.0.0 that would warrant taking action on a 3.x upgrade immediately?

I could certainly use some advice on what makes the most sense - plan to stay in 2.x or move to 3.x before any custom work.

Thanks for any advice in advance....

TJ

Newbie

Posts

Joined
Sun May 13, 2018 10:41 am

Post by MarketInSG » Fri Jul 06, 2018 2:36 pm

From my understanding, there isn't any known serious security flaws that will require you to upgrade your web store (unlike wordpress).

It's safe to stay on OpenCart 2, and if you don't like twig, you can opt to stay on OpenCart 2 too :)


User avatar
Guru Member

Posts

Joined
Wed Nov 16, 2011 11:53 am
Location - Singapore

Post by thekrotek » Fri Jul 06, 2018 3:32 pm

OC 3 has much less extensions available, lots of unresolved issues, including broken cache and might work slower. Basically OC 3 is OC 2.4, it is almost indistinguishable from OC 2.3, so no real reason to upgrade. You won't get any serious advantages, but may get some serious issues.

Professional OpenCart extensions, support and custom work.
Contact me via email or Skype by support@thekrotek.com


User avatar
Active Member

Posts

Joined
Sun Jul 03, 2016 12:24 am

Who is online

Users browsing this forum: No registered users and 6 guests