Post by Softiweb » Mon Jan 22, 2018 7:31 am

Hello,
I made a module for opencart-3.0.2.1b and i am new to opencart. How do I know if it works for other versions of Opencart like 3.0.0.0, 3.0.1.1, 3.0.1.2, 3.0.2.0. Do you have to install all the versions and do the tests one by one or there is another test method?
Thanks for your advices.

Newbie

Posts

Joined
Wed Nov 01, 2017 3:18 am

Post by Johnathan » Tue Jan 23, 2018 3:28 am

No easy way without downloading and installing it on all the other versions. If you plan on developing for OpenCart, I'd highly recommend setting up a localhost installation of each version, so you can test on multiple versions easily.

In terms of this particular extension, OpenCart 3.0 versions are pretty similar, so in all likelihood it will work on all of them. It depends on what it does and if you modify any core files, of course.

Image
Image Image Image Image Image Image


User avatar
Global Moderator

Posts

Joined
Fri Dec 18, 2009 3:08 am


Post by Softiweb » Tue Feb 27, 2018 8:54 pm

Thank you for your reply.
For security reasons, I will be installing all versions of OpenCart locally from version 3.0.0 for my tests.

Newbie

Posts

Joined
Wed Nov 01, 2017 3:18 am
Who is online

Users browsing this forum: No registered users and 15 guests