Post by vanda » Sun Jan 15, 2017 10:25 pm

I'm having the following problem:
I'm using the latest version of OpenCart (2.2.0.3) with SSL on my server. I've configured it to use SSL (Settings->Server) and changed the HTTPS configurations in the main config.php and admin/config files. and i log into admin but it's show message on URL"Not Secure https://gf168.asia/admin/index.php?route=common/login"

and
about infront I click on "login" menu show "Not Secure https://gf168.asia/index.php?route=account/login"

So, my question is: Did i forget something, or is it a bug?
Thank you.

Attachments

Front End Show.PNG

Front End Show.PNG (8.68 KiB) Viewed 2550 times

Front End Show.PNG

Front End Show.PNG (8.68 KiB) Viewed 2550 times


New member

Posts

Joined
Sat Nov 19, 2016 11:46 pm

Post by rjcalifornia » Mon Jan 16, 2017 1:02 am

The "Not Secure" warning might be due to that you are including elements (such as images) via http ( not via https )

I tried loading your site and it is giving me errors. Did you change the site configuration?

Image


Active Member

Posts

Joined
Fri Sep 02, 2011 1:19 pm
Location - Worldwide

Post by vanda » Tue Jan 17, 2017 4:41 pm

"I think you need add Https in your source file to fix this issue.​"

I config in config.php already. And apply in "yes" in SSL in admin tap already.

How can i know about the places for add https in my sour file ot fix this issue?
Can you guide me step by step?



Thank for helpful.

New member

Posts

Joined
Sat Nov 19, 2016 11:46 pm

Post by phenomena » Tue Jan 17, 2017 5:30 pm

vanda wrote:"I think you need add Https in your source file to fix this issue.​"

I config in config.php already. And apply in "yes" in SSL in admin tap already.

How can i know about the places for add https in my sour file ot fix this issue?
Can you guide me step by step?



Thank for helpful.
are you sure that you installed the SSL certificate correctly? i had the same issue when my hoster forgot to load the chain of intermediate certificates, they just loaded the main certificate, and without the chain of intermediate certificates the connection may be still defined as unsecure

Opencarting
Image


User avatar
New member

Posts

Joined
Tue Jul 03, 2012 2:18 am
Location - Ukraine

Post by rjcalifornia » Wed Jan 18, 2017 3:14 am

Code: Select all

are you sure that you installed the SSL certificate correctly?
Looks like there is a problem with the certificate. Check with your hosting provider about this issue.

Image


Active Member

Posts

Joined
Fri Sep 02, 2011 1:19 pm
Location - Worldwide

Post by vanda » Wed Jan 18, 2017 10:04 am

I'm not sure because I watch youtube.com and others reference for configuration.

many steps i config by youtube video tutorials and search more but i don't know it's complete or not?

1. Change "http://" to "https" under line commends "https" in front and admin "config.php"
2. go to admin page ---> setting ---> setting ---> Edit ---> click server tap ---> scroll down find "use ssl" ---> click "yes" ---> Save

yes, all.

if it's not complete please guide me. thank you for helpful.

New member

Posts

Joined
Sat Nov 19, 2016 11:46 pm

User avatar
Active Member

Posts

Joined
Fri Mar 27, 2015 11:13 pm
Location - Denver, Colorado, USA
Who is online

Users browsing this forum: JNeuhoff and 7 guests