Search found 230 matches

Search found 230 matches

Re: Automatically remove decimal places in price for product

You can use round function to your choice... return round($string, 0, PHP_ROUND_HALF_UP); below examples ho to be rounded if you use some of this functions... echo round(9.5, 0, PHP_ROUND_HALF_UP); // 10 echo round(9.5, 0, PHP_ROUND_HALF_DOWN); // 9 echo round(9.5, 0, PHP_ROUND_HALF_EVEN); // 10 ec...

Jump to post
  • Fri Feb 01, 2019 8:08 pm
  • Replies 5
  • Views 633
Re: Automatically remove decimal places in price for product

This works but it only strips “.00” if you have “.37” or “.04” etc it won’t strip out the decimal. Anyone know how to do that?

Jump to post
  • Fri Feb 01, 2019 5:09 pm
  • Replies 5
  • Views 633
[SOLVED] 10 second Delay when placing an order

Ok managed to figure this one out sort of The store is a Multistore. It is always (!!!) the same: seems that nobody is reading the forum rules and what to post: https://forum.opencart.com/viewtopic.php?f=176&t=200480&p=707152#p707152 Unfortunately most people don't read these days and nobody likes ...

Jump to post
  • Tue Dec 11, 2018 6:57 pm
  • Replies 7
  • Views 361
Re: RE: 10 second Delay when placing an order

Ok managed to figure this one out sort of The store is a Multistore. Mail works for Store 1 but not for Store 2 Only way to get that to work is to use SMTP which causes the delay So fixed with adding 1. https://github.com/pekka2/OpenCart-Migration-Upgrade-Tool/blob/master/bugs_2.3.0.2-fix.ocmod.xml ...

Jump to post
  • Sat Dec 08, 2018 8:51 pm
  • Replies 7
  • Views 361
Re: RE: 10 second Delay when placing an order

thekrotek wrote:
Fri Dec 07, 2018 4:19 pm
Such issues don't have generic solution and the only way is to look for the root of the issue right on your server.
Could you be a little more specific as to what and where on the server?

Error Logs are empty, VQMODs errors are nil and OCMODs are fine as well

Jump to post
  • Sat Dec 08, 2018 3:44 pm
  • Replies 7
  • Views 361
Re: RE: 10 second Delay when placing an order

1. Which OpenCart version you are using exactly? 2. Have you installed any additional extensions (which might produce this delay)? 3. Maybe your server is holding back the output - have you checked this (who is your provider)? 4. Does it work without delay when you are using the php-mail protocol? ...

Jump to post
  • Sat Dec 08, 2018 3:33 pm
  • Replies 7
  • Views 361
[SOLVED] 10 second Delay when placing an order

Hey guys,

Using SMTP to send mail via Google Gsuite account.

The order goes through fine and email is working but it hangs on the checkout for 10 seconds after a customer places an order.

Has anyone else experienced this?

Regards,
Motion :crazy:

Jump to post
  • Fri Dec 07, 2018 1:04 pm
  • Replies 7
  • Views 361
Re: Zapier or API availability?

ocdev wrote:
Sat Nov 10, 2018 12:01 am
Anyone come up with a solution to integrate with Zapier?
No and any attempt to collaborate gets shut down pretty quickly. I would love to show the code I got from Zapier developer who disappeared from the face of the earth but sadly commercial licenses don't allow it

Jump to post
  • Sat Nov 10, 2018 8:33 am
  • Replies 15
  • Views 6332
Re: RE: Automate Mailchimp Campaign based on OpenCart Order

Cheers Paul, figure it out. Using Clear Thinkings Mailchimp Pro Intergration, so now I just have to trigger and set up automation in mailchimp ;)

Jump to post
  • Wed Sep 26, 2018 7:55 am
  • Replies 6
  • Views 167
Re: RE: Automate Mailchimp Campaign based on OpenCart Order

khnaz35 wrote:
Tue Sep 25, 2018 5:33 pm
Welcome Champ, if couldn't get any one about it you can make a commercial request on it :joker:
That's an option too, would like someone to explain the process before committing to a commercial solution. Hard to find a transparent developer these days ;)

Jump to post
  • Tue Sep 25, 2018 5:42 pm
  • Replies 6
  • Views 167
Re: RE: Automate Mailchimp Campaign based on OpenCart Order

khnaz35 wrote:
Tue Sep 25, 2018 1:26 pm
Write to mailchamp or browse their knowledge base
Thanks champ, one step ahead of you there. Actually seeking anyone who has done this already in the OC community O0

Jump to post
  • Tue Sep 25, 2018 3:21 pm
  • Replies 6
  • Views 167
RE: Automate Mailchimp Campaign based on OpenCart Order

Hey guys, I have a client who wants to automate their mailchimp campaigns in OpenCart when a customer places an order. What they want is a few different campaigns 1) Welcome email that goes out when a customer signs up 2) Customers who buy something get a newsletter sent one week after buying someth...

Jump to post
  • Tue Sep 25, 2018 12:05 pm
  • Replies 6
  • Views 167
Re: PHP Warning: Division by zero in /public_html/system/library/template/Twig/Environment

straightlight wrote:
Thu Sep 13, 2018 8:44 pm
Revert back to the default theme and see if the issue can be reproduced.
Doesn't happen on the default theme. Only the Journal Theme. So I guess we have narrowed down that something in Journal is causing it

Jump to post
  • Sat Sep 15, 2018 10:27 am
  • Replies 18
  • Views 1506
Re: PHP Warning: Division by zero in /public_html/system/library/template/Twig/Environment

straightlight wrote:
Thu Sep 13, 2018 8:44 pm
Revert back to the default theme and see if the issue can be reproduced.
Only way I can do that is creating an DEV clone, guess that's the only option though now

Jump to post
  • Thu Sep 13, 2018 9:02 pm
  • Replies 18
  • Views 1506
Re: PHP Warning: Division by zero in /public_html/system/library/template/Twig/Environment

straightlight wrote:
Thu Sep 13, 2018 7:41 pm
More information is needed. Using the default theme or custom theme?
Using the Journal 2 Theme

The only Twig thing that I can think that would be causing the issue is related to these mods
https://imgur.com/a/9omZT8f
in the new theme editor

Jump to post
  • Thu Sep 13, 2018 8:05 pm
  • Replies 18
  • Views 1506
Re: PHP Warning: Division by zero in /public_html/system/library/template/Twig/Environment

How do I find the route location if the error log points to /public_html/system/library/template/Twig/Environment.php By always focusing on the URL of the page you are visiting. There have been 60 Occurrences of this error since 2018-09-12 01:28:06 It Last appeared on: 2018-09-12 22:48:58 If I clea...

Jump to post
  • Thu Sep 13, 2018 7:25 am
  • Replies 18
  • Views 1506
Re: PHP Warning: Division by zero in /public_html/system/library/template/Twig/Environment

The file you are addressing is only the source of the reference where a specific TWIG file contains the definite problem. More information is needed. From which route location specifically are you encountering this error message? The location of the error message is in the error.log How do I find t...

Jump to post
  • Wed Sep 12, 2018 10:13 pm
  • Replies 18
  • Views 1506
Re: PHP Warning: Division by zero in /public_html/system/library/template/Twig/Environment

Bump still have this error on PHP Warning: Division by zero in /home/fridaysc/public_html/system/library/template/Twig/Environment.php(403) : eval()'d code on line 82 What's weird is Line 82 is not source code, it's a comment in the PHP file <?php /* * This file is part of Twig. * * (c) 2009 Fabien ...

Jump to post
  • Wed Sep 12, 2018 8:56 am
  • Replies 18
  • Views 1506
What is this file for? system/library/template/Twig/Environment.php

Hey guys,

What is this file for and how is it created?
system/library/template/Twig/Environment.php

Regards,
Motion

Jump to post
  • Wed Sep 12, 2018 8:51 am
  • Replies 2
  • Views 120
Re: system/library/template/Twig/Environment.php(403) : eval()'d code on line 466

I'm having the same issue on OC 3.0.2.0 and the extension above hasn't helped, really annoying error this one

Jump to post
  • Wed Sep 12, 2018 8:07 am
  • Replies 3
  • Views 1679

Search found 230 matches