Search found 7073 matches

Search found 7073 matches

Re: Stripe Extension opens white screen after entering api's

Sounds like an issue with your extension. Are you using my Stripe Payment Gateway ? If so, contact me here for support: www.getclearthinking.com/contact If you're using some other Stripe extension, you should contact that extension's developer to see if they can take a look. There's likely a bug in ...

Jump to post
  • Fri Nov 16, 2018 10:28 pm
  • Replies 1
  • Views 43
Re: New Shipping Extension ERR_EMPTY_RESPONSE

Yes, manually remove all extension files to fully uninstall it. You can find out what the files are by unzipping the installation bundle and then going through them one-by-one, finding them on your server, and deleting them.

Jump to post
  • Fri Nov 16, 2018 6:06 am
  • Replies 4
  • Views 81
Re: How can I add some codes in <body> </body> or <head> </head> tags

If you want to manually add the code yourself, just edit your theme's header template file:

/catalog/view/theme/YOURTHEME/template/common/header.tpl

Jump to post
  • Fri Nov 16, 2018 6:04 am
  • Replies 5
  • Views 92
Re: Editing .twig files with PHP

You need a space between "if" and your custom constant BONUS_CARD_ENABLE. Also, I'm not sure if you can use constants that way in Twig. If it doesn't work, then use a normal variable instead. You'd do that by adding a line like this in the /catalog/controller/product/product.php file: $data['bonus_c...

Jump to post
  • Fri Nov 16, 2018 6:03 am
  • Replies 2
  • Views 65
Re: New Shipping Extension ERR_EMPTY_RESPONSE

If the /admin/controller/extension/shipping/usps_stamps_smart_flexible.php file is missing, then you try re-installing the extension. You may have installed the wrong version, or the bundle didn't install properly for some reason. If it's just the missing file that's the issue, re-installing should ...

Jump to post
  • Fri Nov 16, 2018 1:43 am
  • Replies 4
  • Views 81
Re: [Use older payment module on newer version of opencart?] [PP_standard]

What you probably want to do is compare the lines that these XML files reference, then look for the corresponding lines in the new files. They might be the same (they're not too complicated) or pretty close, so you'd just need to adjust a few pieces of code. Since these mods aren't super complex, it...

Jump to post
  • Thu Nov 15, 2018 10:44 pm
  • Replies 3
  • Views 138
Re: Payment methods and stock status

I don't have a solution for your stock issue, but for limiting payment methods based on the products in the cart, I have a Restrict Payment Methods extension that can do that. You could then set up a restriction like this, so that "Pay in Store" is only available if those expensive products are NOT ...

Jump to post
  • Thu Nov 15, 2018 10:36 pm
  • Replies 1
  • Views 39
Re: [Use older payment module on newer version of opencart?] [PP_standard]

No, extensions from one OpenCart version will usually not work on another version, and 2.1 extensions will definitely not work on 3.0. There are too many internal changes. What you'd have to do is update all the code for the 2.1 version to turn it into a 3.0-compatible extension, but since it's a bu...

Jump to post
  • Thu Nov 15, 2018 12:06 am
  • Replies 3
  • Views 138
Re: [UPDATED] Braintree Payment Gateway Pro

Updated to v302.5 Release Notes: - NOTE: Make sure to save your settings after updating to this version, since there are new settings - Added: separate button styling options for the PayPal buttons - Added: separate setting for enabling/disabling PayPal - Added: support for a PayPal Credit button, ...

Jump to post
  • Wed Nov 14, 2018 2:55 am
  • Replies 12
  • Views 4000
Re: [UPDATED] Braintree Payment Gateway

Updated to v302.5 Release Notes: - NOTE: Make sure to save your settings after updating to this version, since there are new settings - Added: separate button styling options for the PayPal button - Added: separate setting for enabling/disabling PayPal - Fixed: "Device Data" wasn't being captured i...

Jump to post
  • Wed Nov 14, 2018 2:53 am
  • Replies 29
  • Views 12758
Re: [RELEASED] 3.0.2.0 Bug Fixes

Usually, yes. But the 3.0.2.0 situation has gotten ridiculous --- many of these are FROM github, and most of those fixes were within a few months of release. Instead, here we are 16 months after release with no 3.0.2.1, even though that was possible over a year old. The OpenCart team could have (and...

Jump to post
  • Tue Nov 13, 2018 10:47 pm
  • Replies 2
  • Views 127
Re: [UPDATED] TaxJar Integration

Updated to v302.2 Release Notes: - Fixed: "Undefined variable: product_totals" error - Fixed: untaxed products and Order Totals are now passed to TaxJar as exempt, to prevent errors with mismatching totals - Fixed: "A non-numeric value encountered" error if no fallback rate is used - Updated: exten...

Jump to post
  • Tue Nov 13, 2018 2:35 am
  • Replies 1
  • Views 322
Re: Pin Certain Product to top of Category?

There's no way to do this in OpenCart using the settings, so you'd have to modify the controller file yourself. That would be in the controller file you mentioned, you'd have to hard-code some product_id's into the data array, based on the "path" in the URL. It's possible but not simple, so it's som...

Jump to post
  • Tue Nov 13, 2018 2:31 am
  • Replies 10
  • Views 291
Re: Error message in log file : Indirect modification of overloaded property

That error is on a vQmod cache file, so this is most likely being caused by a mod you've installed that has a bug in it. Try disabling anything in /vqmod/xml/ that affects the front-end display of the customer's orders (by renaming the .xml file to .xml_). If that doesn't work, then the cache file h...

Jump to post
  • Tue Nov 13, 2018 2:22 am
  • Replies 1
  • Views 66
[RELEASED] 3.0.2.0 Bug Fixes

http://image.opencartx.com/data/3.0.2.0-bug-fixes/3.0.2.0-bug-fixes-banner.png Current Version: v302.1 ( release notes ) OpenCart Versions: 3.0.2.0 To Purchase: Visit OpenCartX or opencart.com http://image.opencartx.com/data/buttons/contact-clear-thinking.png This ocMod extension fixes known bugs i...

Jump to post
  • Tue Nov 13, 2018 12:50 am
  • Replies 2
  • Views 127
Re: newbie

OpenCart doesn't have an import/export function like you're describing, so you must be using an extension. Contact the extension developer for support, or look to see if there are any forum help topics for your particular extension.

Jump to post
  • Sat Nov 10, 2018 5:48 am
  • Replies 4
  • Views 144
Re: newbie

Your post is a little vague. Where are you doing this site restoring? Are you using an extension for your import? What's your OpenCart version? If you're not using OpenCart but your web host panel, people in the forum here may not be able to help you. In that case, contact your web host for support.

Jump to post
  • Fri Nov 09, 2018 10:37 pm
  • Replies 4
  • Views 144
Re: Syntax error: unexpected token < in JSON at position 0

Your SMTP settings in System > Settings > Mail are wrong. Double-check those, or switch from SMTP to the php "Mail" function. Your issue is definitely a mail issue, so you must have wrong settings in there. If you can't figure it out, you'll probably need to hire someone to assist with this, or figu...

Jump to post
  • Fri Nov 09, 2018 10:32 pm
  • Replies 1
  • Views 67

Search found 7073 matches