Search found 46 matches

Search found 46 matches

Re: JS & CSS does not call

I know it is old subject but it has not issue. I had similar problem but in Opencart 3. I published fix the problem in this subject: viewtopic.php?f=202&t=207541

Jump to post
  • Fri Oct 12, 2018 12:27 am
  • Replies 6
  • Views 1214
Re: Loading styles in new position module

OK. I found my own problem. The problem is the order loaded the controllers. Controller header must by loaded as last. My old code in category controller: $data['column_left'] = $this->load->controller('common/column_left'); $data['column_right'] = $this->load->controller('common/column_right'); $da...

Jump to post
  • Fri Oct 12, 2018 12:23 am
  • Replies 1
  • Views 52
Loading styles in new position module

Hi I have problem with few new positions module. Positions load modules coretlu but not load styles which are declared in module controller. I saw on the forum that similar problems were in Opencart 2, but no solution was given there. Someone knows something? I don't see this problem on start page.

Jump to post
  • Fri Oct 12, 2018 12:02 am
  • Replies 1
  • Views 52
Re: Load module model

Qphoria the model class is not empty. It has example, tested method . Maybe problem is in class name. So I have two files that work together. First controller: path: catalog/controller/extension/module/dc_modulename.php class name: ControllerExtensionModuleDcModulename in this file I try load model ...

Jump to post
  • Thu Oct 11, 2018 3:11 pm
  • Replies 8
  • Views 141
Re: Load module model

Yes, but when I was pasting an error into the post, I changed the name of the module. So don't look at this module name. I paste agein errors: Fatal error: Uncaught Exception: Error: Could not load model module/ds_modulename! in \vqmod\vqcache\vq2-C:_xampp7_storage_modification_system_engine_loader....

Jump to post
  • Wed Oct 10, 2018 5:55 pm
  • Replies 8
  • Views 141
Re: Load module model

Somebody have any idea?
Hov load a model from catalog/model/extension/module/dc_modulename.php
in controller catalog/controller/extension/module/dc_modulename.php
??? :-\

Jump to post
  • Wed Oct 10, 2018 5:28 pm
  • Replies 8
  • Views 141
Re: Load module model

I'm sorry it is mistake but only in my post.
In code names of modules are coretly.

Jump to post
  • Wed Oct 10, 2018 2:05 pm
  • Replies 8
  • Views 141
Load module model

Hi I have controller in catalog/controller/extension/module/dc_modulename.php and I have model in catalog/model/extension/module/dc_modulename.php Model has name ModelExtensionModuleDcModulename when I try load model in controller by this code $this->load->model('extension/module/dc_modulename'); .....

Jump to post
  • Wed Oct 10, 2018 12:34 pm
  • Replies 8
  • Views 141
Variable with theme path or theme name

Hi

How get variable with theme name or theme path?
I try use $config->get('config_theme') but it's not working.

Jump to post
  • Mon Oct 08, 2018 1:26 pm
  • Replies 2
  • Views 63
How get products list with only id and name col

Hi
How get products list with only id and name col?

now I use $this->model_catalog_product->getProducts();

but this function get all data. I need only id and name

Jump to post
  • Sat Oct 06, 2018 6:17 pm
  • Replies 1
  • Views 66
Opencart Marketplace and invoice

Hello, I want to buy an extension on Opencart Marketplace but I need an invoice for the company. There are fields in the user account only for name and surname. In the EU I need: company name and VAT number. How do I add these details to my account?

Jump to post
  • Tue Oct 02, 2018 10:58 pm
  • Replies 1
  • Views 71
Few files twig in admin module.

I'm writing module in admin panel. I want to have a form divided into several parts. Each part of the form I want to have in a separate file so that the code is not too long. How to load a view of one module with a few twig files? Please help

Jump to post
  • Tue Oct 02, 2018 12:05 am
  • Replies 2
  • Views 139
Problem with GLOB_BRACE

Hi I have new Opencart version on Strato.de hosting. On local host and another hosting shop worked fine. On strato.de I have problem with error: Notice: Use of undefined constant GLOB_BRACE - assumed 'GLOB_BRACE' in domain.de/admin/controller/marketplace/extension.php on line 32 Warning: glob() expe...

Jump to post
  • Mon Aug 27, 2018 9:33 pm
  • Replies 1
  • Views 111
New module position

Hi
Is it possible to add a new position for module, without modifying core files? For example, vqmod or something else?

Jump to post
  • Sat Jun 02, 2018 1:14 pm
  • Replies 2
  • Views 213
Re: Language code in header.tpl

Ok I paste in controller header code:
$data['language'] = $this->session->data['language'];
and
code echo $language;
in header.tpl not work.

Are You sure. It not work for me?

Jump to post
  • Tue May 22, 2018 11:34 am
  • Replies 2
  • Views 123
Language code in header.tpl

Hi I use Opencart 2.3 and i need variable with language code in header.tpl file. I use this code (I found this code in this forum) echo $this->session->data['language']; but it causes an error. <b>Notice</b>: Undefined property: Template\PHP::$session in <b>C:\xampp7\htdocs\immunology-shop\catalog\v...

Jump to post
  • Tue May 22, 2018 12:03 am
  • Replies 2
  • Views 123
Re: Import pliku xlsx z produktami poprzez moduł Export/Import Tool (V3.20)

Na tych screenach nic nie widać. Dali funkcje miniatur bez możliwości powiększenia ??? :|

Jump to post
  • Fri Apr 20, 2018 4:20 pm
  • Replies 2
  • Views 6325
Re: After migrate, image menager stoped working.

I have solved the problem!!! :joker: :crazy: :drunk: :laugh:
In the directory with the images there was a jpg file with size 5MB. After deleting the file, the manager started to work.
It's strange to me, but it helped.

Thank you all for your commitment in topic.

Jump to post
  • Thu Apr 05, 2018 10:42 pm
  • Replies 23
  • Views 1176
Re: After migrate, image menager stoped working.

I checked Config twice. Incorrect paths cause errors to be displayed. There is also something interesting here. When I get the wrong path to Image, the Image Manager turns on. However, it does not show any images or folders. When I try to upload a file, a message pops up saying that the directory do...

Jump to post
  • Thu Apr 05, 2018 10:31 pm
  • Replies 23
  • Views 1176

Search found 46 matches